If you use this site, you agree to our use of cookies. Learn more | Accept

Export, import, exchange projects

iTaskX offers a high degree of compatibility, letting you easily exchange your projects over the following Industry-Standard formats:

XML - for MS Project and other projectmanagement applications

The MS Project XML Format can be used to exchange projects with MS Project 2003, 2007, 2010, 2013 and 2016. iTaskX and Microsoft Project can read and write this format. In iTaskX it's also possible to read MPP files but it's not possible to write them.

Export XML files in iTaskX:

  1. Point to „File” > „Export To” > „XML...” in the iTaskX menu bar.
  2. Click „Next...” and save your file.

Import or open XML files in iTaskX:

In iTaskX you can choose if you like to import an XML file in a existing document/project or open the XML file in a new document.

  • To import an XML file in a existing document/project, point to „Insert” > „Project from File...” in the iTaskX menu bar.
    If you only want to import the task or resource list from the XML file you can choose „Insert” > „New Tasks from File...” or „Insert” > „New Resources from” > „File...”.
  • To open an XML in a new document/project, point to „File” > „Open” and choose your XML file.

Open XML files in MS Project:

  1. In MS Project, on the File menu, click Open.
  2. In the Open dialog box browse to the location of the XML file you want to open
  3. You must manually select XML Format (*.xml) or All Files (*.*) in the Files of type list to display XML files in the Open dialog box!
  4. The Import Wizard starts.
  5. Select how you want to import the XML file, and then click Finish.

Notes

  • You can also open a Project XML file by browsing to the file by using a Windows Explorer window, right-clicking the file, and then selecting Microsoft Office Project on the Open with menu. If you use this method to open a Project XML file, you immediately see the Import Wizard.
  • iTaskX 3 doesn't support the MPX format to exchange files because this format is outdated, use the MS Project XML format instate.
CSV - for Excel, Numbers and other spreadsheet or text applications

The CSV format ist the best way to exchange projects with spreadsheet applications. iTaskX can import and export this format.

Export CSV files in iTaskX:

  1. Point to „File” > „Export To” > „CSV...” in the iTaskX menu bar.
  2. By default iTaskX exports the visible columns of the current view. If you want to export other columns you can use the „+” and the „-” button under „Exported Fields” to add or remove them.
  3. Click „Next...” and save your file.

Import CSV files in iTaskX:

To import the task or resource list from an CSV file you can choose „Insert” > „New Tasks from File...” or „Insert” > „New Resources from” > „File...”.

ICS - for macOS and iOS Calendar and other calendar applications

If you want to exchange data between iTaskX and calendar applications use the .ICS format. iTaskX can import and export this format. Beside the macOS and iOS calendar application this format is supported by Google Calendar, Microsoft Outlook, Lotus Notes and many other. iTaskX also support the creation of special calendars for individual resources.

Export ICS files in iTaskX:

  1. Point to „File” > „Export To” > „ICS...” in the iTaskX menu bar.
  2. Choose your options.
  3. Click „Next...” and save your file.

Import ICS files in iTaskX:

To import the task list from an ICS file you can choose „Insert” > „New Tasks from File...”.

OPML - for mind map applications

Use the .OPML format to exchange projects with mind map applications. iTaskX can import and export this format.

Export OPML files in iTaskX:

  1. Point to „File” > „Export To” > „OPML...” in the iTaskX menu bar.
  2. Click „Next...” and save your file.

Import OPML files in iTaskX:

To import the task list from an OPML file you can choose „Insert” > „New Tasks from File...”.

Image (BMP, GIF, JPEG, PNG, TIFF) and PDF

Choose this option to save a big picture of the current view in the selected format.

  1. Point to „File” > „Export To” > „Image...” (or „PDF”) in the iTaskX menu bar.
  2. Choose your options.
  3. Click „Next...” and save your file.