If you use this site, you agree to our use of cookies. Learn more | Accept

Recommended workflow

10 steps for a successful project with iTaskX.

1. Start a project

The usual way to start to use iTaskX is to create a new blank project plan. It’s also possible to base your new file on an existing project or template that contains tasks resources that are like those you need.

Play Movie
2. Define / check working times

In iTaskX, the default working times are 8:00 AM to 5:00 PM weekdays, with an hour off for lunch. You can set calendars for your whole project, specific tasks and resources doing work on the project.

To set up working times in iTaskX choose „Edit” > „Working Times…” or use the Edit Working Times toolbar icon.

Note
When you edit working times it’s recommended to adjust the calendar defaults in the „Project Options”
To change the project options in iTaskX choose „Edit” > „Project Options…” in the menu bar or use the Show Project Options toolbar icon.

Play Movie
3. List tasks in your project

Begin your project by listing the tasks that have to be done to complete it. List tasks in chronological order. Use descriptive names, preferably including a verb and a noun. For example, „Draft research proposal" or „Submit research proposal to steering committee".

First, list the large phases (summary tasks) of the project, then add detail to each phase by listing the individual tasks in that phase. Later, you can indent these tasks under each phase to create an outline.

If you don't know the details for a phase, you can use the phase as a place holder and complete the details later.

In the „Duration” column, enter the time required to complete each task, as a number followed by „m” for minutes, „h” for hours, „d” for days, „w” for weeks or „mo” for months. Don't enter start and finish dates yet!

If you are not sure about the duration, you can enter a „?” after the duration value to indicate an estimate.

Notes

  • By default new tasks have estimated durations. You can change this in „Edit” > „Project Options…” in the menu bar or use the Show Project Options toolbar icon.
  • Mark tasks that represent major events in the project as milestones by entering a „0" duration.

Hint
Holding down the „CTRL” ⌃ or „CTRL” ⌃ and „ALT” ⌥ key while clicking or right mouse click on a row brings up a shortcut menu which is listing the commands you can use. iTaskX has several shortcut menus. Use shortcut menus to save time and make it easier to work with iTaskX files.

Play Movie
4. Organize tasks into phases

Organize your project by creating a hierarchy. Where tasks are similar or will be completed in the same timeframe, indent them under a summary.

To outline tasks into phases, enter the name of each phase followed by the tasks that make up the phase.
Next, select the tasks that make up the phase and indent them under the task that represents the phase. This will automatically change the task above into a summary. After you made this summary task, the Duration field shows the total duration of the phase, based on the subtasks indented below it.

To indent or outdent tasks, select the desired task(s) and choose „Edit” > „Task” > „Indent” or „Outdent” in the menu bar or use the Indent or Outdent mini toolbar icon.

Play Movie
5. Create dependencies between tasks

One of the most critical steps in scheduling is to create task dependencies, or links. This step makes the difference between a plan that can be used as an effective management tool and a plan that can only be used as a presentation tool.

A dependency occurs when the start or finish of one task depends upon the start or finish of another. Most tasks are dependent upon other tasks. After the dependencies are set, you can easily identify the critical path and understand the driving factors for the project end date. You can also easily make changes to one task and immediately see the ripple effect it will have on the rest of the plan. This is where iTaskX shows its power as a project management tool.

The challenge planners have is to ensure that all tasks are in the dependency chain. Here is a good rule of thumb: every task should have a predecessor unless it is driven by the start date of the project. Every task should have a successor unless it is the last task or milestone in the project.

To link tasks, select the desired tasks and choose „Edit” > „Task” > „Link” in the menu bar or use the Link mini toolbar icon.

If two tasks need to overlap one another, or if they are dependent but there needs to be a gap between them enter Lead or Lag time.

To enter lead or lag time edit „Predecessor” in the „Entry Info” inspector Entry-Info-Inspector or type the predecessor task's ID number, appropriate dependency abbreviation: SS (Start-to-Start), FF (Finish-to-Finish), FS (Finish-to-Start), or SF (Start-to-Finish) and the lead or lag time directly in the „Predecessor” or „Successor” column. For example, 6FS+1 d (predecessor / successor task's ID 6, Finish-to-Start link, + 1 day lag time).

Play Movie
6. Specify people, equipment and cost

It is important to determine what type of resources you need to assign. For example, you can assign named resources, such as „Christian Vieboeck”, or generic resources, such as „Programmers”. If you are early in the project-planning stage, you might want to use generic resources.

You can also assign material resources such as computers, or other types of materials and costs.

To create a resource list switch to the „Resource Sheet” view with the „View” toolbar icon and enter „Work”, „Material” and „Cost” resources with all available values like „Standard Rate”, „Overtime Rate”, „Calendar”… Work resources can also imported from the macOS Contacts application when you choose „Insert” > „New Resource from” > „Contacts” in the menu bar.

Play Movie
7. Assign resources

After you have added resources to your project, you can assign them to tasks. Try to assign resources always to subtasks, not summery tasks. This helps you to create and maintain more effective and manageable projects.

If your task type is Fixed Units and you are using effort-driven scheduling, which is default, the duration of the task will shorten as you assign more resources. If you change the task type to „Fixed Duration”, the duration will remain fixed, and work or units will change.

Notes

  • You can change defaults for new tasks in „Edit” > „Project Options…” in the menu bar or use the Show Project Options toolbar icon.
  • To assign a resource, select the desired task and click the Assign mini toolbar icon or choose the resource directly in the „Resource Names” field. It’s also possible to assign resources with the „Entry Info” inspector Entry-Info-Inspector in the „Resource Assignments” pane.
Play Movie

At this time you're ready to present, report or share your plan and to use it to track and manage your project.

8. Present, report, share

With iTaskX, you can create many kinds of reports of whatever data you want without having to use any other software. You can create PDFs, text files, printouts… from every view and share them via email, iCloud…

In iTaskX it’s also possible to create custom views for presentations and reports beside the predefined views.

To create a predefined report choose „Reports” from the „View” toolbar icon and select the desired report.

To create custom views open the „Navigation” area with the „Layout” Layout toolbar icon and click on the „+” button. After that you can set up this new view with the columns you like.

To mange columns hover your mouse over the header of the table view and click on the black triangle or use the columns list in the iTaskX library Columns list.

Play Movie
9. Baselines

Before you start tracking your schedule, you should save a baseline so that you can compare it with your up-to-date schedule later in the project.

A baseline is a group of some primary reference points, like start dates, finish dates, durations, work, and cost estimates that you can set to record the original project plan when that plan is completed and refined. As the project progresses, you can set additional 10 baselines to help measure changes in the plan. For example, if your project has several phases, you can save a separate baseline at the end of each phase, to compare planned values against actual data.

Because the baseline provides the reference points against which you compare actual project progress, the baseline should include your best estimates for task duration, start and finish dates, costs, and other project variables that you want to monitor.

To set a baseline choose „Tracking” > „Save Baseline…” in the menu bar.

After you set a baseline, you can compare it with the scheduled and actual data to see how your project is tracking against your initial goals.

Play Movie
10. Tracking

Tracking your project and ensuring that it stays on target are the real guts of project management. Building a good plan is not nearly as hard as keeping that plan on track after reality sets in and starts taking your wonderful plan apart.

There are two commonly used methods of updating a project plan in iTaskX with the status of your project work. The first uses percent complete to take a general measure of how „finished” a task or assignment is. The second uses a collection of actual work done by resources.

The percent complete method is faster than the actual work method, but it gives a much more general, higher-level view of status. The actual work method takes a bit more time and requires more detailed communication between the project manager and the resources, but it also provides much more detailed information about where the work is being done and where trouble might be.

Percent complete

The percent complete method uses the general feelings of the resource or the project manager about how complete an assignment or task is. You are asking your resource to tell you what percentage of the work is complete.

To enter this information choose the „Resource Usage” view > „Work Table” („View” toolbar icon) and add your values in the „(%) Work Complete” field.

Actual work

The actual work method is basically the same as percentage complete, except it offers more detail. The actual work approach is normally used when a resource uses a timecard to track how many hours are spent working on each task for a given time period.
Depending on your own processes, these could be daily or weekly time periods. The reporting of the work done for these time periods is typically handled on a weekly basis.

To enter thins information choose the „Resource Usage” view > „Work Table” („View” toolbar icon). This view allows you to enter actual work on a time-period-by-time-period basis. Hover your mouse over the header of the „Details” column and click on the black triangle to choose „Actual Work”.
Now you can enter your actual information for all resources and assignments.

Play Movie